72 Imperial climate control

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
Anyone have any recommendations on removing heater core from 72 Imperial? Manual says to remove entire fan box from firewall which looks easy in the book but not on the car given all the sealants, etc. Any suggestions on where to find core? Also, the auto temp controller is not functioning and I've heard they are available rebuilt? Thank you.
 

saforwardlook

Old Man with a Hat
FCBO Gold Member
Joined
Oct 8, 2011
Messages
7,104
Reaction score
11,932
Location
California
The heater core comes out through the interior and yes, you do have very tight access all around but it can be done. Just be prepared to curse a lot.

The system used in 1972 is Auto Temp II and the controllers and amplifiers are available remanufactured from Performance Analysis Company. The original Chrysler controllers were made of bakelite plastic and the housings cracked after only a couple years of use and they were junk. Chrysler sold the patent rights to Mercedes Benz in those years and MB copied them but used aluminum housings that do not crack. You need to send in your old core and they will take the internals and rebuild them and put them in an aluminum box just like Mercedes designed and used. You will live happily ever after then. You should also inquire about the availability of check valves for the system too. I did all this on my 1972 Imperial and it has worked fine for more than 10 years now.

Performance Analysis | Climate Control | Diaphragms | Blower Motors | Pushbutton Panels | Vacuum Door Locks | Autotemp | Cruise Control | Engine Oil Analysis | Mercedes-Benz Parts | Mercedes-Benz Club of America | Oak Ridge | Car Care - Home | Performance Analysis Co.

They are also very willing and helpful in getting your system to work properly if you run into any issues.

Autotemp II is the only Autotemp system that can actually be brought back into good working performance and was available in the 1971-3 C body models. The other systems before and after are problem laden and often have low success rates from what I am aware of from others on this forum.

New exact replacement heater cores and condensers are available from a company detailed in this thread from the past.............................

AC Global
 
Last edited:

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
Awesome, and thanks so much for your reply and info. I had been considering going with a universal system from Vintage Air but it appears that it would be upwards of $2k along with a lot of custom fitting on my part. Of course I would like to preserve the original look too.
 

CBODY67

Old Man with a Hat
Joined
Mar 27, 2011
Messages
7,291
Reaction score
4,447
Glad you desired to keep everything OEM rather than Aftermarket! It could well be that in order to use any aftermarket hvac system, on an orig factory a/c car, you might need to fab up some flat metal for the firewall/cowl as I suspect many of those "universal" systems were really meant to upgrade non-a/c cars, which would have different "holes" in the firewall than a factory a/c car would. More time/money for a possibly less-than-stellar result?

The OTHER thing is that should you decide to sell the car, that "made to fit, universal" hvac system might detract/scare off some potential buyers more than a non-functional AutoTemp II system might. I know that unless I had the connections that @saforwardlook has or has made, I would NOT want a universal aftermarket system, even if it might work decently well. Just my orientation as I suspect that at least an OEM system can be downgraded to a non-AutoTemp system to make it work, with salvage yard sourced items. BUT I might be incorrect in that orientation, too!

Thanks for that link and information, @saforwardlook!

Just some thoughts,
CBODY67
 

saforwardlook

Old Man with a Hat
FCBO Gold Member
Joined
Oct 8, 2011
Messages
7,104
Reaction score
11,932
Location
California
One additional thought is that I choose to stay with the R12 or freon refrigerant rather than switch over to the 134A newer one. R12 runs at lower pressures and in my experience, the RV2 compressors on our cars seem to last longer at lower operating pressures with R12. It is still available but over time it will become harder to get/more expensive since by law it is illegal to produce any new R12.

Another additional thought, it is often not possible to replace the receiver driers on our cars without damaging the condensers since the coupler between the two seizes up over time and trying to get them apart usually ruins the condenser ( I have yet to use Kroil on those couplers so maybe it will do the job and make the replacement less of a problem). AC Global also makes exact replacement condensers for our cars in addition to the heater cores. No other company makes direct fit replacement condensers for our cars that I have been able to find. Their direct fit condensers are also designed to perform well with 134 refrigerant that requires more efficiency out of them than the older R12 original condensers so the ability to achieve lower temperatures is also enhanced a bit when one of our original condensers is also changed out.
 

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
Thanks again for all of your assistance! I have reached out to Performance Analysis and Hilltop to see what of these parts they would be able to supply. I think I will pull the front passenger seat to give me more room to start working on things. I'm not as flexible as I used to be. Also, what do you know about the in dash "thermostat" or temp control unit and what would need to be done to that to make sure it is in working order? The vacuum lines actually don't look bad but I assume I should probably replace those as well. A am not familiar with AC Global and couldn't find much on line. Do you have contact info? I apologize, I am new to forums like this so not sure how to navigate too well yet. Thanks!
 

saforwardlook

Old Man with a Hat
FCBO Gold Member
Joined
Oct 8, 2011
Messages
7,104
Reaction score
11,932
Location
California
No problem Scott, helping others is part of why we are here.

Regarding getting the heater core, I usually just order mine through Ebay. Here is a link to the one you need:

69 70 71 72 73 Dodge Plymouth Chrysler A/C Dual Heater Core Coil Heat HC5777 NEW | eBay

If you need a condenser as well, then search for 1972 Imperial condenser and one from ACGlobal will come up too.

For the Auto Temp II upper dash push button control unit, the part number is 3431019 and is available from Deception Pass Motor Parts in Anacortes, WA:

http://www.dpmotorparts.com/inventory_4_b.cfm

He shows he has one left in stock and Len is meticulous about keeping his inventory current and is very good to deal with and has good prices relative to other suppliers. Arizona Parts is also a good supplier but Marty there is showing he has none of those left.

Those rarely go bad in my experience so you might want to make the other changes and try out the system before actually ordering one or you may want to have a spare on hand for the future.

Also, for removal of the heater core, besides taking out the right front seat, you will also need to take out the right kick panel and the door sill plate and do your best to get the carpet and carpet pad out of the way. That will give you much better access to the lower housing screws which are the most difficult ones to access for me at least (as best I can recall since the last one I did was several years ago now). You will also need to remove the glove box and a couple of the a/c ducts that go behind that area. Those ducts are very securely attached so pry gently side to side to get them off the center distribution vent and the lower right vent/outlet. So be careful with removing those ducts since if you don't do so gently side to side, you may well end up breaking one of those a/c outlets.

Keep in touch as you proceed as necessary.
 
Last edited:

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
Hey, thanks again for all the tips/info. I am very excited about getting started on this. I’ve been putting it off for 12 years functioning only with limited heat that was either full on , or off. But when core started leaking it forced my hand. I will update as I proceed- hopefully starting this weekend. Your expertise and assistance is greatly appreciated!
 

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
No problem Scott, helping others is part of why we are here.

Regarding getting the heater core, I usually just order mine through Ebay. Here is a link to the one you need:

69 70 71 72 73 Dodge Plymouth Chrysler A/C Dual Heater Core Coil Heat HC5777 NEW | eBay

If you need a condenser as well, then search for 1972 Imperial condenser and one from ACGlobal will come up too.

For the Auto Temp II upper dash push button control unit, the part number is 3431019 and is available from Deception Pass Motor Parts in Anacortes, WA:

Search Mopar Inventory: Len Dawson's Deception Pass Motor Parts - NOS Mopar

He shows he has one left in stock and Len is meticulous about keeping his inventory current and is very good to deal with and has good prices relative to other suppliers. Arizona Parts is also a good supplier but Marty there is showing he has none of those left.

Those rarely go bad in my experience so you might want to make the other changes and try out the system before actually ordering one or you may want to have a spare on hand for the future.

Also, for removal of the heater core, besides taking out the right front seat, you will also need to take out the right kick panel and the door sill plate and do your best to get the carpet and carpet pad out of the way. That will give you much better access to the lower housing screws which are the most difficult ones to access for me at least (as best I can recall since the last one I did was several years ago now). You will also need to remove the glove box and a couple of the a/c ducts that go behind that area. Those ducts are very securely attached so pry gently side to side to get them off the center distribution vent and the lower right vent/outlet. So be careful with removing those ducts since if you don't do so gently side to side, you may well end up breaking one of those a/c outlets.

Keep in touch as you proceed as necessary.
Happy New Year and wanted to reach out with an update and few more questions. I have installed new evaporator and heater core from ac global and had the servo rebuilt by Performance Analysis and installed that on vehicle. I have not charged the refrigerant yes as I am going to replace hoses first. Before I started this project the servo was bypassed and hoses connected directly to core and I would have heat on Hi-defrost but no fan on any other settings. I now can get no response from any settings. I do see movement of vacuum dash pots and am able to hold 12-15 inches of vacuum while tapped into red lined vac. Line. Would you have any ideas as where to start troubleshooting? I have checked all the fuses I can find. Thanks in advance for any insight.
 

thethee

Well-Known Member
Joined
Feb 13, 2021
Messages
623
Reaction score
575
Location
Netherlands
1641748993004.png


This is what my FSM says about it, there is probably a similar service diagnosis chart in your manual. If you're seeing dash pots move it sounds to me like an electrical problem.
 

BigAsAWhale

Member
Joined
May 3, 2014
Messages
57
Reaction score
41
Location
Tampa Bay, Florida (Weeki Wachee)
If you haven't already you may need to replace the amplifier and blower motor. The blower motor tends to draw excess current with age. Mine worked but was much better after replacement. Also, there is a vacuum switch for the blower. The contacts get pitted and cause a poor connection. I took mine apart and cleaned it up, then i put in a relay to take the load off that vacuum switch.
 

saforwardlook

Old Man with a Hat
FCBO Gold Member
Joined
Oct 8, 2011
Messages
7,104
Reaction score
11,932
Location
California
When you get no response from the Autotemp system, it usually means one of the vacuum check valves in the system has failed. Check with Performance Analysis on whether they can supply you with some or can recommend a vendor for them. If you can find someone with an Autotemp II tester, try using that as well. Those vacuum check valves are located conveniently at the front of the floor tunnel just under the blower outlets. Change them all out.

Also, Performance Analysis company is very helpful in helping you trouble shoot your system so do not hesitate to call them to discuss symptoms/issues and they will lead you through the diagnostic process or maybe loan you a tester.

Please report back on how it goes...................................you will get there.................................
 

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
If you haven't already you may need to replace the amplifier and blower motor. The blower motor tends to draw excess current with age. Mine worked but was much better after replacement. Also, there is a vacuum switch for the blower. The contacts get pitted and cause a poor connection. I took mine apart and cleaned it up, then i put in a relay to take the load off that vacuum switch.
Thanks-all good info. I had tested the master blower switch and it was functioning properly and I knew the fan motor was operating before I started this project. I ended up determining that apparently vac lines were reversed at the canister. I had never messed with them but when I reversed suddenly everything started working as it should including temp control. I do hear a small vac leak on low def that stops if I push in on button so I guess I need a new one of those. Anyway, thanks for everyone’s help!
 

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
When you get no response from the Autotemp system, it usually means one of the vacuum check valves in the system has failed. Check with Performance Analysis on whether they can supply you with some or can recommend a vendor for them. If you can find someone with an Autotemp II tester, try using that as well. Those vacuum check valves are located conveniently at the front of the floor tunnel just under the blower outlets. Change them all out.

Also, Performance Analysis company is very helpful in helping you trouble shoot your system so do not hesitate to call them to discuss symptoms/issues and they will lead you through the diagnostic process or maybe loan you a tester.

Please report back on how it goes...................................you will get there.................................
I did ask him about the check valves when I sent the servo and amp to him and he said he didn’t have those. Everything on the heat side appears to be functioning properly now that I found reversed vac lines. Going to have new hoses put on ac lines then get that going and see how everything works together. Thanks again
 

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
I did ask him about the check valves when I sent the servo and amp to him and he said he didn’t have those. Everything on the heat side appears to be functioning properly now that I found reversed vac lines. Going to have new hoses put on ac lines then get that going and see how everything works together. Thanks again
Oh, one more question for you unrelated to ATC. I purchased a new master cylinder from NAPA and when I went to install I found that both of my line fittings at cylinder are 1/2”. The master cylinder has one 9/16 and one 1/2”. NAPA says only one specified. Any experience with this issue? Thanks
 

saforwardlook

Old Man with a Hat
FCBO Gold Member
Joined
Oct 8, 2011
Messages
7,104
Reaction score
11,932
Location
California
The fittings should be different, the one at the front of the master cylinder when installed on your car being 9/16 and the rear one being 1/2. The wrench used to put both of them on would be a 9/16. If you have master cylinder #2006 from NAPA, it is indeed the correct one for your car unless someone changed the line at the front of your master cylinder that goes to the brake distribution valve on your car to a 1/2" nipple at the master cylinder end and adapted another master cylinder from another application to mate with it.
 

Scott Emerson

New Member
Joined
Dec 3, 2021
Messages
11
Reaction score
3
Location
Maryland
The fittings should be different, the one at the front of the master cylinder when installed on your car being 9/16 and the rear one being 1/2. The wrench used to put both of them on would be a 9/16. If you have master cylinder #2006 from NAPA, it is indeed the correct one for your car unless someone changed the line at the front of your master cylinder that goes to the brake distribution valve on your car to a 1/2" nipple at the master cylinder end and adapted another master cylinder from another application to mate with it.
It is indeed a #2066 and I had backed out both fittings to verify my suspicions and they are both 1/2". Strange. Everything appears to be original in patina and if something was converted they sure did a neat job of it. Brake lines are perfectly coiled, routed, etc. I guess I need to figure out some type of adapter or something. Thanks.
 

saforwardlook

Old Man with a Hat
FCBO Gold Member
Joined
Oct 8, 2011
Messages
7,104
Reaction score
11,932
Location
California
It is indeed a #2066 and I had backed out both fittings to verify my suspicions and they are both 1/2". Strange. Everything appears to be original in patina and if something was converted they sure did a neat job of it. Brake lines are perfectly coiled, routed, etc. I guess I need to figure out some type of adapter or something. Thanks.
Personally, I would just replace the incorrect line from the distribution valve to the front master cylinder port with a correct one from Right Stuff brake lines: HKT7201

Talk to one of the Right Stuff sales reps and ask to just buy the one (or both might be an easier ask since they would be very inexpensive) lines from the master cylinder to the distribution valve and be done with the issue once and for all (i.e. don't buy all 4 front lines that you probably do not need unless your car has been in a rust inducing climate).

Otherwise, you need to be sure the master cylinder you would buy to replace the one presently on the car would have the same volumetric capacity, front and rear, as the correct original one and the same mating provisions to the brake booster as original so you don't have to readjust freeplay settings to get adequate pedal travel. That actually fixes the problem rather than just prolong it for you at a later date or for the next guy that you sell your car to if/when that ever happens........................

That would be a relatively easy, quick job to replace that one line and use the master cylinder from NAPA. 15 minutes max. I have used the master cylinders from NAPA and they always have been just fine.

One other thought - Right Stuff is not always correct on their lines, but so far for me at least the ones from master cylinder to distribution valve are bent correctly but ask them to be sure the fitting on the front is 9/16" where it connects to the master cylinder and that the rear one is 1/2". I only suggest this because maybe the ones who replaced those one or two lines to the master cylinder before might have come from Right Stuff.

I believe their line sets for fuselage C bodies with disc brakes are pretty much correct finally after going round and round with them to get them correct but I do believe their lines for the drum brakes cars are not correct yet. Also, for 1969 and 1970 C bodies with disc brake systems, the front brake line set has 5 lines and the 1971 and up fuselage C bodies have 4 lines sets since the delay valve used in the 69-70 systems was determined not worth the added expense since it really wasn't significantly effective in reducing rear brake lock up on panic stops.
 
Last edited:
Top