72 Imperial Wipers

Electrical & Ignition

  1. Toomunsch

    Toomunsch New Member

    Messages:
    13
    Likes Received:
    26
    Joined:
    Mar 18, 2019
    Location:
    Milwaukee, WI
    The 3 speed windshield wipers work but don't park. I heard there is a contact in the motor that sometimes needs to be cleaned up to fix this. Anyone have info on this, pic maybe? Or do I need a new motor? Thx
     
  2. CBODY67

    CBODY67 Senior Member

    Messages:
    3,681
    Likes Received:
    829
    Joined:
    Mar 27, 2011
    Check the downloadable FSM at www.mymopar.com. Might even by some Chrysler MasterTech videos in the www.mymopar.com archives, too?

    Usually, there is a "park switch" on all windshield wiper motor mechanisms. Not sure if contact cleaning might help, as it's usually a wear issue rather than something getting dirty. Not to say that a cleaning might help things, though.

    CBODY67
     
  3. traintech55

    traintech55 Senior Member

    Messages:
    3,272
    Likes Received:
    1529
    Joined:
    Jul 23, 2015
    Location:
    Hammond, IN.
    Oh Gawd, I have not worked on one of those in 40 years. I remember a little limit switch on the cover for the motor, (Held down by three small screws). When you turn the wipers off, the current is reversed to run the motor backwards. this switch is closed, and when the wipers get to the park position, a cam on the motor open this switch and breaks the circuit. More than likely this switch is broken, and probably not available anymore.
     
    • Thanks! Thanks! x 1
  4. Welder guy

    Welder guy Senior Member FCBO Gold Member

    Messages:
    4,448
    Likes Received:
    5440
    Joined:
    Dec 30, 2016
    Location:
    Millet Alberta
    • Like Like x 1