Booster blues

John Kirby

Active Member
Joined
Jun 3, 2016
Messages
203
Reaction score
97
Location
Minneapolis , Mn
I'm sure this topic has been brought up frequently.

My booster isn't working as good as it should. It works but I can't lock up the brakes. Used to be able to. Back in the late 80's I did the disk brake swap from a '72 Newport to my 66 New Yorker. It worked well for many years until the master cylinder puked into the booster. So I tossed the booster back around 2004 and went with this:
IMG_0884[1].JPG


All ma mopar stuff so it bolts right up. It is an 8" booster but I don't remember where I got it from anymore. After years of working on the car with extended periods of it sitting that info is lost. I have an electric vacuum pump that creates 22" of vacuum, that is sufficient. I did the classic booster check: step on the brakes and wait until the vacuum comes up. Pedal drops about 1" or so. The vacuum pump also shuts off for long periods when it reaches max vacuum, no vacuum leaks. So the booster is good. Just not enough surface area to apply sufficient force to the master cylinder push rod. My guess is I need a booster from a '72 but they are not available from any parts stores. I did check with napa and they don't have one but they do have a photo. It looks like it will fit, the pedal rod length is right and the bolt pattern looks right.
Anyone have any ideas on this? It's one of the last items I need to deal with so I can go on a road trip and take her to the local car shows.
 

WOT440

Member
Joined
Jul 27, 2019
Messages
109
Reaction score
69
Location
USA
Did you check there is a preload on the push rod when installing the MC? Should be around 1/8 inch.
 

Sixpactogo

Active Member
Joined
Aug 22, 2015
Messages
203
Reaction score
190
Location
Wisconsin
It has been my experience with disk brake upgrades from drum brakes, the single diaphragm booster does not supply enough boost. It looks like you have the drum brake booster mounted. I would give Cass at Doctor Diff a call. 406 883 4772.
 

Davea Lux

Old Man with a Hat
FCBO Gold Member
Joined
Mar 27, 2017
Messages
8,795
Reaction score
7,907
Location
Cornelius Or
The booster you have appears to be a Midland single diaphragm booster, that unit was not usually used with disc brakes. There were two different boosters used with C-Body disc brakes in '72. First was the large diameter Bendix single diaphragm booster, the second was a Midland tandem booster. Neither of these is going to be an off the shelf item as rebuilders quit stocking them years ago. Your best bet is probably going to be finding a rebuildable unit at a vintage wrecking yard and sending it out for repair to Booster Dewey or a similar high quality shop.

Dave
 

John Kirby

Active Member
Joined
Jun 3, 2016
Messages
203
Reaction score
97
Location
Minneapolis , Mn
Thanks for the replies. I figured this wasn't the right replacement booster. I did find a '72 version at French Lake Auto Parts. Not bad since they are only 40 miles away or so. It came off DM41M2D172407. I'm guessing that's a Dodge Polara 4 dr sedan. Should be here next week.

Once I get it installed I will sell the smaller booster somewhere to recoup most of the cost. Anyone know what mopar vehicles use this unit?
 

Ross Wooldridge

Senior Member
FCBO Gold Member
Joined
Apr 25, 2016
Messages
4,154
Reaction score
3,440
Location
Scotland, Ontario, Canada
FYI - your '72 booster that you're getting will work well, but it will interfere with your shifter linkage if you have column shift. You may find that you're not able to select Low 2 and Low 1...

I had a 72 booster on my 66 Chrysler disc system, and that's what I experienced.
 

EurekaSevven

Active Member
Joined
Jan 14, 2021
Messages
207
Reaction score
80
Location
North Carolina
I've wondered if you can install those reproduction B/E Body Bendix boosters in place of the C-Body one, and if it'll bolt in with minimal modification.
 

EurekaSevven

Active Member
Joined
Jan 14, 2021
Messages
207
Reaction score
80
Location
North Carolina
I saw the thread here, from what I remember, one of the rods for the piston(?) was slightly different in length, and I think the bolting was a little different to the firewall, but it was otherwise the exact same part. I think the place where the brake pedal mounts onto the booster itself had a slightly different geometry for the B/E bodies than the C bodies from the measurements, which doesn't make any sense why Chrysler designed it like that, but I wonder how big of a deal that actually is, brake-travel-wise. My memory is fuzzy on the differences.

Perhaps I should be the first to try when I get all my parts to my 1972 disc brake setup and assemble it once I rebuild the calipers and assemble everything...
 

Big_John

Illegitimi non carborundum
FCBO Gold Member
Joined
May 21, 2013
Messages
15,129
Reaction score
20,030
Location
Marcellus, NY
My booster isn't working as good as it should. It works but I can't lock up the brakes. Used to be able to.
So the booster is good.

OK, it seems to me that if this worked before, something has changed.

While I agree that this probably isn't the correct booster, since it still works, and your brakes worked before, isn't it possible you have a problem elsewhere?

Are you saying that the pedal pressure is so high that you can't push it? Or do the brakes just not perform like they should and the pedal pressure is OK?

There's a lot of issues that make it so you can't lock the brakes... Bad pads, stuck calipers, bad hoses etc. But even with limited assist, if everything else is working correctly, it still should work, just might have to push harder (even use two feet LOL).
 

John Kirby

Active Member
Joined
Jun 3, 2016
Messages
203
Reaction score
97
Location
Minneapolis , Mn
FYI - your '72 booster that you're getting will work well, but it will interfere with your shifter linkage if you have column shift. You may find that you're not able to select Low 2 and Low 1...

I had a 72 booster on my 66 Chrysler disc system, and that's what I experienced.
So it's a good thing I installed the console and floor shifter several years ago.
 

John Kirby

Active Member
Joined
Jun 3, 2016
Messages
203
Reaction score
97
Location
Minneapolis , Mn
OK, it seems to me that if this worked before, something has changed.

While I agree that this probably isn't the correct booster, since it still works, and your brakes worked before, isn't it possible you have a problem elsewhere?

Are you saying that the pedal pressure is so high that you can't push it? Or do the brakes just not perform like they should and the pedal pressure is OK?

There's a lot of issues that make it so you can't lock the brakes... Bad pads, stuck calipers, bad hoses etc. But even with limited assist, if everything else is working correctly, it still should work, just might have to push harder (even use two feet LOL).

It does work, pedal pressure is high to get it to stop. Not like when I had the previous booster. Previously all I had to do was stomp on the pedal and the tires would lock up. Now it does stop but it takes a lot more effort.

As I think more about it, the booster was changed when I was in the middle of doing body/paint work. So I didn't do any driving on the road. Just moving it in/out of the garage as needed. I think it may have been this way for quite a while and I didn't notice it. The calipers and wheel cylinders were replaced within the last year as I was chasing down this problem. I replaced the prop valve and rear lines at this time too. It did make a difference when when I adjusted the rear brakes. That cleared up the pedal going half way to the floor.
 

John Kirby

Active Member
Joined
Jun 3, 2016
Messages
203
Reaction score
97
Location
Minneapolis , Mn
I saw the thread here, from what I remember, one of the rods for the piston(?) was slightly different in length, and I think the bolting was a little different to the firewall, but it was otherwise the exact same part. I think the place where the brake pedal mounts onto the booster itself had a slightly different geometry for the B/E bodies than the C bodies from the measurements, which doesn't make any sense why Chrysler designed it like that, but I wonder how big of a deal that actually is, brake-travel-wise. My memory is fuzzy on the differences.

Perhaps I should be the first to try when I get all my parts to my 1972 disc brake setup and assemble it once I rebuild the calipers and assemble everything...

Bolting to the firewall shouldn't be that difficult. On my 66 there is a thick plate behind the booster for structural support. It will make a good template for where to drill holes. The critical thing is the pedal rod needs to be centered in the large hole in the center. I'm not sure about the rod length. If the pedal eye is removable it shouldn't be that difficult to make an extension. You may be able to shorten or lengthen one and thread the pieces with an appropriate die. Use a hex threaded standoff to extend it.
upload_2021-10-16_22-26-40.png
Along with a couple nuts to lock it in place. Make sure its steel, not aluminum. And as I posted in another thread, use washers behind the nuts bolting it to the firewall. It you do try it, let us know how it works. A solution to the lack of boosters for c-bodies is a continuing issue.
 
Top