Good day, new member here... 1st time posting a pic, hope it works...

62newportnewbie

New Member
Joined
Feb 15, 2022
Messages
33
Reaction score
29
Location
nw wisconsin
Gonna sit by the fire and think a while

WIN_20220216_10_00_31_Pro.jpg
 

62newportnewbie

New Member
Joined
Feb 15, 2022
Messages
33
Reaction score
29
Location
nw wisconsin
Thank you... I will keep that in mind.. my car seems mostly complete.. but i do for sure need a 14" rim for a spare tire?

Would you be willing to ship a rim without a tire?
 

62newportnewbie

New Member
Joined
Feb 15, 2022
Messages
33
Reaction score
29
Location
nw wisconsin
Pulled the mechanical pump out... fuel pump rod seems ok idk... I have done some research on the rods etc... I have decided to go with an electric pump, and see if that eliminates this issue.

I am trying to stay on a low budget with this car, and would like to get it on the road for less than $500 ( In addition to the purchase price )

So far i am up to around $100 --- 1 tube for one tire that would not hold air, some paint and various chemicals, and the mech fuel pump ($24 )

If i can get rid of this tapping noise, then i would still be on track maybe ha

WIN_20220217_07_59_22_Pro.jpg
 

62newportnewbie

New Member
Joined
Feb 15, 2022
Messages
33
Reaction score
29
Location
nw wisconsin
Went to town, and back again.. decided to go with high quality, made in USA K&N pump... going to plumb it, wire it up quick, and heat up the block again to see if this takes care of the tapping noise...

There is no point in working on the car any longer if it needs major engine work, there is no way that would happen before spring, so hoping this works.

Pump was $59 - well worth it to stop a knock i hope

WIN_20220217_08_54_23_Pro.jpg


WIN_20220217_08_53_58_Pro.jpg
 
Last edited:

bluefury361

Old Man with a Hat
Joined
Mar 9, 2011
Messages
14,105
Reaction score
16,257
Location
Alabama Gulf Coast
Welcome, nice Chrysler.
Just a slight amount of ware on the fuel pump rod will cause the tapping noise you speak of.
Should you decide to change it, look for a NOS Mopar rod from the era. Mopar performance replacements can be trouble prone. Probably Chinese.
 

Snotty

Senior Member
FCBO Gold Member
Joined
Aug 18, 2015
Messages
4,433
Reaction score
3,336
Location
Chico, California
Well, i got the pump on... squirted a little gas down the carb and it fired up... took a couple times, and some rough running for a bit, but then it smoothed out and ran ok...

i am not too happy as there is a light "knock" or tapping noise coming from the front of the motor it seems ugh
I had a similar thing on the 413 in my '62. I thought the rids were going as it really knocked at start up and shut down. Turned out to be a shot harmonic balancer! Discovered this when trying to time the motor and the mark kept moving.

Grab your balancer and see if it moves with the engine not running.
 

62newportnewbie

New Member
Joined
Feb 15, 2022
Messages
33
Reaction score
29
Location
nw wisconsin
Well, even an old hound dog finds a bone, and gets lucky now and then..

I got the electric pump on, its a nice quality unit ( The wirenuts are temporary, had to see if this fixed it as quick as possible ha )... pumps fuel nice and KNOCK IS GONE

I did not drill a hole in the frame, i was able to use an existing hole..

The motor runs pretty nice, no smoke, starts up with turn of key, sounds decent.

Very pleased with this car so far... Feel very blessed to have found it.

Thank you all for help and ideas - very much appreciated.

There is a pic of the handle leaning up by the grill that saved the day ha.

WIN_20220217_10_55_47_Pro.jpg


WIN_20220217_10_58_02_Pro.jpg
 

Glider

Member
Joined
Jul 18, 2021
Messages
92
Reaction score
28
Location
Tollarp Sweden
Funny; a freind had a Wildcat just like that wile I had a -62 Newport, one of the absolutely best cars I've had & I've had a few houndreds...

hest 2.JPG


hest 3.JPG
 
Top