Heavy leaking around oil pump

Joined
Jun 4, 2019
Messages
64
Reaction score
98
Location
calgary
Hello all. Stock 400 Block on a 78 Newport here, never been apart. We've been driving quite a bit this year and mostly in 60-80 mph range. Recently I noticed quite a bit of leaking around the oil filter/pump area. So I plan first try to tighten the bolts and if that does not help, to remove the pump, replace the gasket and O-rings (or just swap the pump assy altogether). Questions are:
Mopar shop manual in Oil Pump Replacement procedure only says this: (2) Prime Oil pump before installation by filling the rotor cavity with engine oil.
So no need to prime the pump with a drill and rod, etc, etc - it only applies to rebuilt 'dry' engines, correct?

Thank you in advance!
 

cbarge

World Famous Barge in a Budget
FCBO Gold Member
Joined
Nov 22, 2010
Messages
5,025
Reaction score
8,333
Location
Kingston Ontario Eh?
If you are going to handle the oil pump, which requires undoing the left motor mount and raise the engine a bit, (sometimes removing the power steering pump--depending on what type of pump--for access) you may as well replace it.
Not a job that I like to do twice for the same issue.
Get a good quality pump i.e. Melling
for stock application.
No need for a high volume high pressure pump.
Hope this helps.
 
Joined
Jun 4, 2019
Messages
64
Reaction score
98
Location
calgary
If you are going to handle the oil pump, which requires undoing the left motor mount and raise the engine a bit, (sometimes removing the power steering pump--depending on what type of pump--for access) you may as well replace it.
Not a job that I like to do twice for the same issue.
Get a good quality pump i.e. Melling
for stock application.
No need for a high volume high pressure pump.
Hope this helps.
Thank you! Undoing the engine mount is an unwelcome complication, thought I could pull everything out without this much trouble. I should have looked into it when I replaced the mounts a few months back... Yes, I was looking at Melling.
 

Trace 300 Hurst

Professional Tinkerer
FCBO Gold Member
Joined
May 27, 2018
Messages
2,005
Reaction score
2,430
Location
Ponte Vedra Beach, FL
I replaced my leaky oil pump in 15 minutes, no other removals necessary. And agreed, go for the standard Mellings pump (not high volume or high pressure versions, they're totally unnecessary and can overload the drive shaft hex). Sure, get some oil in the pump guts so it primes quickly, and if you use a new filter fill it, too. If not, just screw it back on. A "used" engine will be just fine with a few seconds of no oil pressure.
 

1970FuryConv

Old Man with a Hat
Joined
Aug 8, 2014
Messages
5,190
Reaction score
4,670
Location
Richmond, VA
Hello all. Stock 400 Block on a 78 Newport here, never been apart. We've been driving quite a bit this year and mostly in 60-80 mph range. Recently I noticed quite a bit of leaking around the oil filter/pump area. So I plan first try to tighten the bolts and if that does not help, to remove the pump, replace the gasket and O-rings (or just swap the pump assy altogether). Questions are:
Mopar shop manual in Oil Pump Replacement procedure only says this: (2) Prime Oil pump before installation by filling the rotor cavity with engine oil.
So no need to prime the pump with a drill and rod, etc, etc - it only applies to rebuilt 'dry' engines, correct?

Thank you in advance!
I agree with No need to use a drill and rod prime the whole engine. That generally applies only to dry engines or engines that have sat for a while. Also, it's nice not to have to remove your distributor.

Also agree with stock volume and pressure for street use.
 

Big_John

Illegitimi non carborundum
FCBO Gold Member
Joined
May 21, 2013
Messages
16,334
Reaction score
22,298
Location
Marcellus, NY
First, are you sure it's the pump and not the gasket on the oil filter?

Second, the gaskets on the oil pump are thin "compressed fiber" type and usually don't fail unless it's taken apart. I'd see if the bolts on the pump are tight and snug them up.
 
Joined
Jun 4, 2019
Messages
64
Reaction score
98
Location
calgary
First, are you sure it's the pump and not the gasket on the oil filter?

Second, the gaskets on the oil pump are thin "compressed fiber" type and usually don't fail unless it's taken apart. I'd see if the bolts on the pump are tight and snug them up.
Once the Newport got some lift time, I started small by checking if everything tight. Sure enough, the oil filter was sorta loose. Everything else is tight as a drum. Went for a spin, let it sit for two hours - so far so dry. Weird.
 

74monacoHT

New Member
Joined
Jul 26, 2022
Messages
24
Reaction score
12
Location
Bedford County, Virginia
I swapped my oil pump by taking it apart. The two halves came off and went on without raising engine. Those first few seconds waiting for the pump to prime, and pressure to get above zero, are ... an interesting experience. Hopefully you can avoid all this.
 

Gerald Morris

Senior Member
Joined
Mar 9, 2016
Messages
2,319
Reaction score
1,197
Location
Tucson
You can prime your pump by packing it with Lubriplate or vaseline petroleum jelly. Reinstall it with new gaskets, tighten the bolts to spec, fill the new filter up w at least a pint of fluid, then turn your engine over. I got LOTS of practice with oil pumps the first year I used the 383 I'm still running, over 6 years later.

I suspect loose bolts in your case. Tighten to spec if so. You MAY not NEED to replace anything. Buy several gaskets if the bolts weren't loose. You might get by with that. I too run a Melling, OEM spec.
 
Joined
Jun 4, 2019
Messages
64
Reaction score
98
Location
calgary
You can prime your pump by packing it with Lubriplate or vaseline petroleum jelly. Reinstall it with new gaskets, tighten the bolts to spec, fill the new filter up w at least a pint of fluid, then turn your engine over. I got LOTS of practice with oil pumps the first year I used the 383 I'm still running, over 6 years later.

I suspect loose bolts in your case. Tighten to spec if so. You MAY not NEED to replace anything. Buy several gaskets if the bolts weren't loose. You might get by with that. I too run a Melling, OEM spec.
The oil filter was loose. Also, it is impossible to fill the filter with any amount of oil, as it sits horizontally.
 

Gerald Morris

Senior Member
Joined
Mar 9, 2016
Messages
2,319
Reaction score
1,197
Location
Tucson
The oil filter was loose. Also, it is impossible to fill the filter with any amount of oil, as it sits horizontally.

I KNOW how the filter sits. You just need to hold your thumb over the hole then pop it onto the threaded nipple and turn it on. If you do this right, you will only drip maybe a teaspoon of oil out. IFF you do it, RIGHT that is. Maybe you had better not do it though....
 

1970FuryConv

Old Man with a Hat
Joined
Aug 8, 2014
Messages
5,190
Reaction score
4,670
Location
Richmond, VA
The oil filter was loose. Also, it is impossible to fill the filter with any amount of oil, as it sits horizontally.
I've started many engines after an old change with a dry filter and no problems.

That said, when you add oil to a filter, it will soak into the filter media if you let it sit for a bit. Most of the oil will not come out when you install the filter.
 
Top