1. 71NewYorkMan

    71NewYorkMan Member

    Messages:
    175
    Likes Received:
    128
    Joined:
    Jul 4, 2012
    Location:
    Rincon, GA
    Brand? Type?

    The Pertronix was using the original ballast resistor and ignition coil? Or Flamethrower coil?

    The present ignition system/resistor/ignition coil are all matched?

    Any Pertronix related wiring changes have been changed in favor of the new system?
     
    • Thanks! Thanks! x 1
  2. Matt Conlan

    Matt Conlan Member

    Messages:
    77
    Likes Received:
    6
    Joined:
    Jun 9, 2020
    Location:
    Two Harbors Minnesota
    Thanks for all the suggestions. It's a brand new fuel pump as of last summer. when I crank it, gas comes through in a steady stream. Just checked the carb - blew it out, checked the float, etc. The distributor is brand new. How would I check for spark as its dying? As far as the brand, I bought the ECM, resistor, distributor and new coil from Rick Ehrenberg, so not really a brand name. The Pertronix had the old Flamethrower coil, but it never ran right. I rewired the ignition system as I was putting in the new system. Should be all new.
     
    • Thanks! Thanks! x 1
  3. CBODY67

    CBODY67 Old Man with a Hat

    Messages:
    6,759
    Likes Received:
    1541
    Joined:
    Mar 27, 2011
    FWIW, I like the Holley 2210-family 2bbl. More refined and efficient than the Stromberg WWC and Carter BBD that it replaced. It does have the same issues with the air horn raising in the center due to over-tightening of the air cleaner wing nut as the Strombergs did. The BBDs had their air cleaner stud attached to a heavy wire which attached to the sides of the air cleaner mounting area. But when the air horn deforms, it breaches the float bowl's rear wall and where it seals against the air horn, allowing raw fuel to be pulled into the venturi area when the choke valve closes. One tip-off that this has happened is when the choke valve hangs on the air horn, adjacent to the air cleaner stud. BUT Chrysler put out a TSB and "Bridge Kit" to fix it in 1972. And it worked well as I did that on our '72 Newport 400 2bbl. BTAIM

    When it dies after being run for a while, that's when the inductive timing light can be handy to have nearby, plus a long flat-blade screwdriver to short across the starter relay with the key in "run". Not specifically to check the spark timing, just to check for sparks happening.

    Problem is that "spark" and "fuel" issues can tend to act the same in some situations. Making it difficult to diagnose correctly.

    I have a '68 Buick LeSabre 350. After I got it, I did the normal tune-up stuff to establish a baseline of sorts with it. Plugs, points, wires, etc. One day I had it running and it started to lose rpm. I quickly went to the driver's seat and started pumping the accel pedal and it came back. No real rhyme or reason, but it happened unexpectedly, otherwise running fine. It would do it running down the road, too. The last time it happened I was taking it to my shadetree shop for storage. On the way there, it started dieing out. I'd coast to the shoulder of the access road, put it in "N" and try to start it by pumping the accel pedal quickly until it would catch, then I'd quickly pop it into "D" (one wheel on the dirt) and seek to continue to the shop. That night, it happened a few times, but we finally got there and parked it inside. I got a new fuel pump for it, for good measure.

    One night, I decided to replace the fuel pump, just to know that it had been done. When I started it that night, it sounded better than it ever had since I'd owned it. Problem solved. Obviously, the existing pump had some issue with the valves in it where they would get into a particular position and leak internally between themselves (or something like that). I remembered a late uncle who had a similar situation on his '60 LeSabre. Back when you could rebuild fuel pumps! It was the valves in that pump having issues, too.

    Then, the issue of fuel pump pushrod wear has come up in this forum a good bit lately, too. Something not usually worried about.

    In one respect, it might be ignition as you can get it to start with greatly-advanced timing. Which is where the timing light checks can come in. On the other hand, it could be a fuel issue.

    The fuel pump might be recent, but even with ethanol-resistant diaphrams, allegedly, if the pump is allowed to dry out from non-driving/running, that "resistant" diaphram can allegedly become brittle and have durability issues. But the pump can oily pump so much with a worn fuel pump pushrod (think "decreased lift on the cam lobe" sort of thing, resulting in lower volumes pumped). Maybe a little bit of both?

    Please keep us posted on your diagnostics,
    CBODY67
     
  4. Matt Conlan

    Matt Conlan Member

    Messages:
    77
    Likes Received:
    6
    Joined:
    Jun 9, 2020
    Location:
    Two Harbors Minnesota
    Thanks! Will do. Gonna be a few weeks, it's take the youngest daughter to college week. Then, no kids! Lots of time for Newports! I appreciate all the ideas. I'm a self-taught tinkerer, never had anyone to work on stuff with. I can do the work, but my lack of experience sure shows in diagnostics. Been driving Newports since I was 16. Not gonna let this one get away from me now.
     
    • Like Like x 1
  5. MericaMopar

    MericaMopar Member

    Messages:
    61
    Likes Received:
    12
    Joined:
    Dec 17, 2020
    Location:
    Merica
    heat crossover valve on your exhaust manifold not opening?
     
  6. Ripinator

    Ripinator Old Man with a Hat

    Messages:
    5,385
    Likes Received:
    3066
    Joined:
    Jul 31, 2013
    Location:
    Germantown, MD
    Based on everything you've said, I suspect the problem is associated with a bad ECU or ignition coil. Bad coil problems are especially insidious, because everything appears to be fine during diagnostic tests in the driveway. . . Until the coil gets hot later out on the road. I would try and find a US-made coil somewhere, and go from there - even a used one. Also, if there is a Chinese ECU in the mix, I would replace it too.
     
  7. 70bigblockdodge

    70bigblockdodge Old Man with a Hat

    Messages:
    12,896
    Likes Received:
    5605
    Joined:
    Jan 19, 2013
    Location:
    Avonmore Pa.
    They are talking about the pick up coil in the distributor, it creates the signal that the ECU turns into a open in the ignition coil.
    When they get hot they sometimes do not work. When they cool off they start working again. I have never had on create a driving problem only hot restarts.
    That or the vibration dampener slipping is where I would look.
     
  8. Ripinator

    Ripinator Old Man with a Hat

    Messages:
    5,385
    Likes Received:
    3066
    Joined:
    Jul 31, 2013
    Location:
    Germantown, MD
    Sometimes ignition coils behave the same way as defective pickup coils, when they get hot. . .
     
    • Agree Agree x 1
  9. Matt Conlan

    Matt Conlan Member

    Messages:
    77
    Likes Received:
    6
    Joined:
    Jun 9, 2020
    Location:
    Two Harbors Minnesota
    Do my damnedest to keep Chinese parts out of my cars. My understanding with the Ehrenberg parts is they are made here. So, new coil, new ECU and new distributor. I'll try switching things out to see if I can find the bad one. Don't know how I can test the pickup, though.
     
  10. halifaxhops

    halifaxhops Retired USAF MSGT (SW) yes navy also. FCBO Gold Member

    Messages:
    2,448
    Likes Received:
    705
    Joined:
    Mar 10, 2017
    Location:
    HALIFAX PA
    Yup ECU's also. RE boxes are about as good as you can get now. Way to many fake mopars out there now especially the orange ones.
     
  11. Love Shack

    Love Shack Active Member

    Messages:
    460
    Likes Received:
    488
    Joined:
    Aug 22, 2014
    Location:
    Lake Mills, Wisconsin
    I also had a similar problem with the pick up coil in the distributor on a later model Mopar of mine (1979)
     
  12. 1970FuryConv

    1970FuryConv Senior Member

    Messages:
    2,866
    Likes Received:
    2293
    Joined:
    Aug 8, 2014
    Location:
    Richmond, VA
    I suspect a partially plugged exhaust. If you vacuum test it and rev to 2000 rpm, does vacuum slowly decrease. Perhaps it starts out breathing fine, but back pressure from a clogged exhaust stops letting your engine exhale. Then you stall.
     
    • Like Like x 2
  13. Matt Conlan

    Matt Conlan Member

    Messages:
    77
    Likes Received:
    6
    Joined:
    Jun 9, 2020
    Location:
    Two Harbors Minnesota
    You know, that kinda what I was thinking. I'm going to have to figure out how to test that. Thank you!
     
  14. 1970FuryConv

    1970FuryConv Senior Member

    Messages:
    2,866
    Likes Received:
    2293
    Joined:
    Aug 8, 2014
    Location:
    Richmond, VA
    All you need is a vacuum gauge and a port for manifold vacuum on the carburetor. Connect the hose from the gauge to the port. Start it. Bring up the rpms and see what happens. If the gauge needle starts dropping, Houston we have an exhaust problem.
    Another test is to cut out a small section of pipe in front of the muffler. Usually the muffler is the culprit. If it starts after a no start situation, you will have loudly found your problem.
    Best of luck, Matt! Ben
     
  15. WOT440

    WOT440 Member

    Messages:
    102
    Likes Received:
    37
    Joined:
    Jul 27, 2019
    Location:
    USA
    I had this happen with a clogged catalytic converter. Ran good in the driveway and crapped out after ten/fifteen minutes of road driving. Never died, just had no power. I dis-connected the exhaust to test it.
     
    • Like Like x 1
    • Agree Agree x 1
  16. Gerald Morris

    Gerald Morris Senior Member

    Messages:
    1,822
    Likes Received:
    494
    Joined:
    Mar 9, 2016
    Location:
    Tucson
    "Bad coil" is MY speculation at this point, though with electronic ignition, the pickup or ECU also are suspect. I would try another coil for my sanity check with such symptoms. They can be had cheaply enough. I'm putting a new Taylor Cable one on mine this Fall, when I replace the distributor. I stick with breaker points.
     
    • Like Like x 1
  17. Gerald Morris

    Gerald Morris Senior Member

    Messages:
    1,822
    Likes Received:
    494
    Joined:
    Mar 9, 2016
    Location:
    Tucson
    Had this happen on a '76 Chevy I drove during the early 1980s. I've tried to avoid anything with catalytic converters after that, but its getting harder to do so now....
     
  18. Slap Stick

    Slap Stick Active Member

    Messages:
    213
    Likes Received:
    48
    Joined:
    Dec 3, 2020
    Location:
    St. Charles county, MO
    Let's get some terminology clear. "Cranking" is the same as "turning over".
    At least in my neck of flyover country.
     
    • Agree Agree x 1