Oil Light issue

Omni

Active Member
Joined
Feb 24, 2021
Messages
212
Reaction score
192
Location
43567
Happy Friday to All
Chasing an annoying electrical gremlin on a '65 Newport.
The oil light will not illuminate when the ignition switch is on or accessory. It will flash when you turn the switch off. I have grounded the lead (single gray wire) from the sender with no change.
With the wire either installed on the sender, or grounded with no change, I have ruled out the sending unit. As the light will flash, I believe the circuitry is intact. So that leaves the ignition switch itself. I do have an oil pressure gauge installed, just trying to keep the original system intact.
Anyone have any thoughts? Is my troubleshooting faulty? All comments welcomed.
Thanks for your time.
Omni
 

CBODY67

Old Man with a Hat
Joined
Mar 27, 2011
Messages
7,947
Reaction score
5,039
The circuit is either "on" or "off", nothing inbetween. Are you sure the sending unit is correct for a warning light? Pictures of the sending unit?
 

Big_John

Illegitimi non carborundum
FCBO Gold Member
Joined
May 21, 2013
Messages
16,334
Reaction score
22,298
Location
Marcellus, NY
First thing I would check is the plug right in the center of the cluster. Pins are known to be broken off or the plug loose.

Next thing is to look at the circuit board, making sure it's not broken etc.

The bulb socket is next, and probably right up there with the plug problems. The foil where the socket contacts when it tightens down is prone to tear and the socket could also be loose or the bulb in the socket loose. Look for corrosion too.

Next on the list is the firewall plug and associated wiring on both sides of the firewall.



For reference, a pic I found on the intrawebs.

1650672909238.png
 

D Cluley

Active Member
Joined
Nov 19, 2010
Messages
277
Reaction score
324
Location
Lansing MI
Do the hot/cold lights and the parking brake light work? Those share the power feed with the oil light.
65 oil light.jpg
 

Omni

Active Member
Joined
Feb 24, 2021
Messages
212
Reaction score
192
Location
43567
Good Evening All
The gremlin has been exorcised. The culprit was a defective LED lamp. All is well with the electrical systems (at least for now).

Omni
 
Top