1. Straight eight

    Straight eight New Member

    Messages:
    33
    Likes Received:
    41
    Joined:
    Jan 12, 2017
    Location:
    planet earth
    Hi guys,
    the subject is a 1973 Chrysler New Yorker. I have a slight vibration at 40-50mph....looked today at the transmission mount and it is shot. I wanted to order a new one from "Rockauto" but was a little bit confused: there is a trans mount with two brackets...and the other one has only one????
    https://www.rockauto.com/de/catalog...ransmission-automatic,transmission+mount,8616
    Can someone clarify if both are working. On my car there it seems to me that there is only one bracket....but has not 4 holes for the attaching screws....seems like it is a mishmash of both? Attached are two pictures from "Rockauto"
    Thank you so far, Marco

    a2340__ra_p.jpg

    PC_622340_Rig__ra_p.jpg
     
  2. rkrochen

    rkrochen Active Member

    Messages:
    348
    Likes Received:
    218
    Joined:
    Jun 29, 2015
    Location:
    Teulon, Manitoba
    I believe the second bracket is for an exhaust bracket
     
  3. MrMoparCHP

    MrMoparCHP Senior Member

    Messages:
    4,069
    Likes Received:
    2219
    Joined:
    Aug 9, 2013
    Location:
    Lompoc, CA
    My 69 used the second one.
    Look at your car and see if it has the holes for the extra bracket, someone may have put the wrong one in years ago.
    If not get the style that matches your existing one.


    Alan
     
    • Like Like x 1