73 Monaco Wagon blower/switch not working


Senior Member
Mar 9, 2017
Reaction score
Having a recurring problem on my 73 Monaco wagon.

Fan switch does nothing when either Max AC or AC buttons are pushed. Or nothing is pushed. Just doesn’t work, at any speed. When I push the buttons I can hear a flapper moving. I can feel just a little cool air (passive) coming through front vents.

(However the rear overhead 2nd row AC fans do work - did not think to check if air blowing through is cold)

Had the same problem in the spring, took the plastic dash panels off then and pulled out both the heat/cold push buttons as well as fan switch. Nothing obvious.

I then also pulled fuses, which were all good…there was some light green corrosion on the fuse box terminals I cleaned off. Put everything back together.

It worked. (Why? I don’t know.)

Three months ago. For a while.

Took the car out yesterday. Now the problem is back. No blower activity. I pulled fuses. No corrosion on fuses. No blown fuses.

At a loss to figure this out. I would use a voltmeter but don’t know where to check. Not sure how to get to blower terminals, or I would check them. I fear they are not readily accessible…?
I am having the same problem, almost exactly - what I think is the issue is the blower motor is failing, and in the process is drawing too much amperage, and that has damaged the switch contacts in the vacuum buttons and the fan speed switch with heat so that somewhere within those two assemblies something has melted and won't allow current flow - which necessitates removing both the AC push button assembly and the fan speed switch and either replacing or rebuilding them, and then replacing or rebuilding the blower motor.

In the meantime I ran a heavy gauge wire from the accessory position on the fuse box (with an on off switch from another rear air car to control it with), directly to the fan motor to get the fan to run on high speed. For safety I added an extra 20 amp inline fuse.

In testing and a short drive down the street it worked just fine, but a few minutes down the road the next time and it quit again. This time it had drawn enough amperage that it melted my extra inline fuse holder. The fuse didn't fail... which tells me two things - 1) the fan is drawing a lot of power, close to its limit and may get worse, 2) the inline fuse holder I bought is junk, and the plastic was not spec'd to run that kind of load. Sheesh!

Your blower motor itself doesn't have multiple terminals, only one. The fan's speeds are controlled is actually at the blower motor resistor, which will be located somewhere on the actual heater/ac box. It takes the 3 circuits from the fan speed switch (low, medium, high) and runs each one through a specified resistance to reduce the voltage to the fan blower motor from low to medium to high.

It is designed to get hot, so the resistor assembly is usually found on the side of the heater box, where the resistor coils can be within the box to be cooled by the moving air.

It will look something like this:

The coils are the resistors - if they break, the speed for that particular coil won't work. High speed typically has no resistance on it, or the lowest. All those coils are sent to one wire that goes to the blower motor, on the firewall side, which means it goes back out to the engine bay through the bulkhead connector.

There are things you need to check (not necessarily in this order):

1) Make sure your connections to the blower motor motor resistor are good.
2) Make sure the blower motor resistor is good. Remove it and check it with a meter - if it's got continuity across each terminal then it's OK.
3) Check that there's 12V to the blower motor - that connector will be close to the outside of the blower motor on the firewall.
4) Check that the connection at the bulkhead for the power wire that comes from the blower motor resistor to the blower motor is OK - if it's loose, it might not work, especially if it's heated up.

OK, this is all just off the top of my head, so I hope this helps.
Ross I saw your post yesterday. Fortuitous, I almost chimed in but didn’t want to hijack the post. Highly similar situations. I had trouble Saturday. I need to find the blower motor. Thank you for all the tips. I may end up taking this to the shop. I don’t have a lot of time these days to fiddle around with it. Thanks again. I’ll give some serious thought to all this. I really think the switches are ok and it is as you say, motor or resistor dying.