1. Fratzog

    Fratzog Old Man with a Hat

    Messages:
    9,781
    Likes Received:
    4440
    Joined:
    Nov 12, 2010
    Location:
    Grimsby, Ontario, Canada
    Looks like it should work but being a safety sensitive part make sure.
     
  2. rags

    rags Well-Known Member

    Messages:
    598
    Likes Received:
    279
    Joined:
    Dec 14, 2015
    Location:
    greater norwich metropolitan area
    might have been cool to make an extension with a two bolt flange at each end so it'd be a bolt on. if you tig professionally, i'm sure you'll make it safe.
     
  3. fury1

    fury1 Active Member

    Messages:
    245
    Likes Received:
    240
    Joined:
    Jun 11, 2015
    Location:
    Minnesota
    Heres the end product. I thought about making an extension after I cut it lol. I'm just trying to make this thing drive right now. Next year I'm gonna tear it down and make a lot of things better. I work in a Fab shop. Been welding been welding since I was 16, but professionally since I was 20. This should do the job!



    IMG_20190513_095013443.jpg
     
    • Like Like x 2
    • Agree Agree x 1
  4. fury1

    fury1 Active Member

    Messages:
    245
    Likes Received:
    240
    Joined:
    Jun 11, 2015
    Location:
    Minnesota
    Here it is temporarily installed. Fits good!!

    IMG_20190513_164326662.jpg
     
    • Like Like x 1
  5. fury1

    fury1 Active Member

    Messages:
    245
    Likes Received:
    240
    Joined:
    Jun 11, 2015
    Location:
    Minnesota
    When it rains, it pours. I was gonna reattach the pitman arm and noticed a ton of play in the idler arm. Looks like I'll be replacing that as well! IMG_20190513_165210833.jpg
     
  6. fury1

    fury1 Active Member

    Messages:
    245
    Likes Received:
    240
    Joined:
    Jun 11, 2015
    Location:
    Minnesota
    Got the new coupler in. Also the new idler arm. Just a few things to button up now. Some new rubber next week and she's good to go! Another note. The amp guage seems to be reading negative all the time. Just slightly on the d side of it. Is that normal? Everything is brand new. Alternator. Ignition switch. Voltage regulator. Battery. It does not stay running when I hook up the battery. What could it be? Thanks!!

    IMG_20190516_165823003_HDR.jpg

    IMG_20190516_183118495.jpg
     
    • Like Like x 3
  7. Wilkiethegrid

    Wilkiethegrid New Member

    Messages:
    6
    Likes Received:
    2
    Joined:
    May 18, 2019
    Location:
    Pacifica, Ca.
    Nice project, does the 880 Custom run?
     
  8. fury1

    fury1 Active Member

    Messages:
    245
    Likes Received:
    240
    Joined:
    Jun 11, 2015
    Location:
    Minnesota
    Yup the 880 runs and drives well! That's going to get some attention this fall.
    Here an update on the blue sport fury. Most all odds and ends are buttoned up. New tires last week. Will be ready to go next weekend! Gonna drive it to work a few days this week as well! IMG_20190525_142208030_HDR.jpg IMG_20190525_142227430_HDR.jpg
     
    • Like Like x 1