Disc brake booster question

Knebel

Senior Member
Joined
Mar 21, 2013
Messages
1,534
Reaction score
576
Location
Beaverton, Oregon
I just finished my 4 wheel disc install and just adjusted the prop valve to the rear as good as I could. I started with it being about half way and then slowly gave the rears more pressure. So far it can really put your face in the dash when stepping on it! What a massive improvement over the drums! Also it brakes straight as an arrow. On wet pavement I can lock the wheels up easy when i step on the pedal hard and slide straight as an arrow! I think that is probably good for now.

Question about my booster. Its is an 8" dual with 15/16 disc/disc master from rightstuff and I am using an electric vacuum pump thats avertised to pull 29"HG. I did bleed the brakes and saw no more bubbels. I also benchbled the master! The pedal feels normal as I drive around a bit, when I am just sitting and I push it a bunch..or pump it, I can feel it getting stiffer, like... the vacuum wont assist anymore but the pump is still pulling vac. Is this normal with the booster or do I need to bleed the brakes again? Not sure how to proceed on this currently since I really saw no more air coming out and the brakes grip very good. Oh and the whole booster master contraption shakes quite a lot with the engine running, should I make some reinforcement brackets to make this stiffer or is this okay since it came that way?

Btw the brake hoses dont look like they rub on anything when im at ride height, maybe this was the correct routing afterall, did it according to the instructions!?

20220520_174834.jpg


20220517_161758.jpg


20220521_175123.jpg
 
Generally, in my experience, pumping up brakes does make the brakes stiff. To me that's normal.
I've never seen a master cylinder and brake booster combination shake a whole lot. Usually they just move with the car body. With a smooth running engine, that's not much. That would make me worried that the booster mounting fasteners are not fully torqued.
 
Generally, in my experience, pumping up brakes does make the brakes stiff. To me that's normal.
I've never seen a master cylinder and brake booster combination shake a whole lot. Usually they just move with the car body. With a smooth running engine, that's not much. That would make me worried that the booster mounting fasteners are not fully torqued.
Thank you ill check that. The brackets arent trally that sturdy is what I think.
 
Regardless of the potentially flimsy brackets they sent you (one can likely bend up stronger ones), does that booster use the factory mounting holes in the firewall/support plate? Interested in what our options are for alternatives to the elusive Bendix Dual Diaphragm.
 
Check out the pics in the link. Its just two parallel running bended metal brackets. I migh just weld something on to connect them so they dont move back and forth.
 
Its not deflecting much unless you really really hit the brakes real hard. But still, I dont like it and I will sturdy this up better.
 
Please advise on how you do it - I took a quick look at the brackets on their website, and one has to maintain the ability to unbolt the bracket from the firewall fairly easily while gussetting or boxing that bracket. Not so simple...
 
One more question. I retained the original distribution block and did the rear proportioning valve right after the master before it goes into the block. When i hit the brakes and build pressure, the brake light comes on, does that have something to do with the switch or do I still have air in the line????

 
This switch has a piston in the distribution block. If pressure is reduced to one side of the piston, the piston will shift to an inoperative position. It then makes contact with the switch which grounds the switch and turns on the brake light. I think the problem is that you should have run the front brake lines direct and gotten rid of the distribution block. You could then run the rear lines with your manually adjusted proportioning valve. Another solution if the brakes are performing normally is simply to disconnect the brake warning switch.
 
Ahhh I see. So the switch will see a pressure difference. Does that mean i could hit the brakes and adjust the prop valve til the light comes off and have 50/50 distribution???
 
Little update. I bled the brakes one more time and I really dont see anymore bubbels coming out, however, now the light is on all the time but very dim. It wont light up bright anymore when i push really hard. Common thing for this to get stuck?
 
Little update. I bled the brakes one more time and I really dont see anymore bubbels coming out, however, now the light is on all the time but very dim. It wont light up bright anymore when i push really hard. Common thing for this to get stuck?
Hi Knebel,
Yes, it can get stuck. It really depends on the level of dirt that was in your brake fluid. Either pressure from the front brakes has pushed the piston to the rear brake side and it has gotten stuck or your manual proportioning valve constricts flow even when it's open, causing the piston to stay on the rear brake side. I doubt that you have improperly bled the brakes. If the fluid that is coming out of all 4 bleed valves is clean, I'd say you've done your job. If your brakes are performing normally, for instance no lunging forward because you've only got front brakes or no locked up rears because you've only got rear brakes, you are probably okay. A lot of people trust their foot to detect brake problems much more quickly than a brake light. Thus, you could just disconnect the brake switch and not worry about it if your brakes are performing normally.

Another option, is to disconnect all the brake lines from the distribution block, disconnect the brake switch, and use carburetor cleaner or something else to remove the gum in the distribution block that is causing the piston to get stuck. Then you would reinstall the distribution block, reinstall all the lines, bleed the whole system again, and hopefully fingers crossed have no brake light.

A 3rd option would be to put the manual proportioning valve on the line after the distribution block. That would involve making a line from the master cylinder to the distribution block for the rear brakes, cutting the line from the distribution block to the rear brakes, flaring both sides of the cut, installing the manual proportioning valve, and bleeding the whole system again, plus, in the process, disconnecting the distribution block and cleaning it out somehow so that your brake light switch would work.

A 4th option would be to get rid of the manual proportioning valve, make a line from the master cylinder to the rear brake port on the distribution block, and bleed the whole system again.

In other words, there's lots of options depending upon how much time you want to spend. :lol:Best of luck! Ben
 
I am making new lines and eliminating the block. I will have manual prop valve that will be between master and rear line and then ill just use a tee to do the front. I had ordered brakelines with 3/8 fittings and turns out the fittings were m10 and not 3/8. So gotta wait again because they didnt seal. I had also screwed up and only made single flares, they didnt leak but im changing that to double flare! Why cant anything just work? Lol
 
This is getting frustrating. My adapter for the double flare broke!canted a little bit off center and the small nipple broke off. However, I have 2 single flares left that go to the fronts from the tee so I will probably make new hardlines for the entire front soon if I get a new double flare adapter. Bled everything and nothing appears to leak so will see how it works for now...
 
Back
Top