Weak Blower motor??

darth_linux

Well-Known Member
Joined
Oct 9, 2022
Messages
702
Reaction score
651
Location
Spokane, WA
1966 Chrysler Newport with factory AC.

The output of my blower motor seems weak compared to modern vehicles. I assume that's to be expected, but even with my 3 speed fan on full blast and the setting on DEFROST, the output of air to the windshield is weaker than I expect.

I thought about perhaps pulling the blower motor and bench testing it, or getting a new one from wherever and comparing the two, and perhaps installing the new one, but the FSM says I have to remove the entire heater box assembly from under the dash to change out the blower motor! Is that right? Isn't it just a few bolts holding it in on the firewall?

I've got the extra pair of heater hoses that go into the heater box right near the passenger fender, so I imagine removing the factory AC heater box is a large undertaking and deserving of a full rebuild with new/re-cored heater core and AC evaporator while I have it all apart.

Who's replaced just the blower motor and what was the experience you had? Thanks.
 
It might not be the blower motor. It might be the blend doors binding up or the intakes clogged with dirt.
Could also be that the ducting is loose or deteriorated and air is coming out other places.
 
1966 Chrysler Newport with factory AC.


I thought about perhaps pulling the blower motor and bench testing it, or getting a new one from wherever and comparing the two, and perhaps installing the new one, but the FSM says I have to remove the entire heater box assembly from under the dash to change out the blower motor! Is that right? Isn't it just a few bolts holding it in on the firewall?
I'm pretty sure your blower motor is accessible from under the hood. The FSM is more than likely referring to the Non AC heater box. Are you sure you're getting all three speeds? If so, those blower motors do get dirty and corroded causing slower speeds and high current flow.
 
Before you start tearing into things, consider that the hvac ducting is "slip-fit", possibly having some soft foam filling the saps in earlier times. So "leakage" can occur. Possibly some "duct tape" might help the velocity and volume get to its intended locations?

It is possible that the bushings in the motor are needing some lube, but if they are pulling the motor down, there should be some related noise and possibly some blown fuses. You might inspect the fuses to see if the blower motor fuse is deforming from borderline heat?

Do verify that all of the linkages on the hvac box are working, too. Seems like there are some rubber flaps on the internal doors that might have deteriorated, too?

Just some thoughts,
CBODY67
 
I get "clunks" from the various blend doors as I change from defrost, to heat, to AC, and I can feel air going to the three different locations, just not as much as expected. I'll check out the ductwork and make sure there are no leaks at the joints.
 
I'm pretty sure your blower motor is accessible from under the hood. The FSM is more than likely referring to the Non AC heater box. Are you sure you're getting all three speeds? If so, those blower motors do get dirty and corroded causing slower speeds and high current flow.
Would "electronics cleaner" be a good fix if it's just corrosion in the motor itself?
 
Would "electronics cleaner" be a good fix if it's just corrosion in the motor itself?
Yes and no. More likely no.

It can possibly clean the commutator and brushes, but it's been my experience that those motors get too caked up with crap and really need to be taken apart and cleaned. The other issue is the bushings tend to get dry and gummy and they also need the motor to be disassembled to clean and oil.

So spraying the cleaner might help, but you really would need to soak the motor up and it's going to be messy, so it's really got to come out anyway.

If you have to pull the heater box, you might as well change all the box gaskets and clean it up while it's out... and new motors aren't that expensive.
 
Yes and no. More likely no.

It can possibly clean the commutator and brushes, but it's been my experience that those motors get too caked up with crap and really need to be taken apart and cleaned. The other issue is the bushings tend to get dry and gummy and they also need the motor to be disassembled to clean and oil.

So spraying the cleaner might help, but you really would need to soak the motor up and it's going to be messy, so it's really got to come out anyway.

If you have to pull the heater box, you might as well change all the box gaskets and clean it up while it's out... and new motors aren't that expensive.
At that point, I’d rather just install a new motor!
 
Your 66 will not compete with a new car.

Motor comes out under the hood. When the motor comes out feel around on there for leaves or a mouse nest, but usually you can hear it running on the blower wheel.

take it apart then clean and lubricate it like big John said. Bearings, armature, brushes, etc.

are your running the blower motor with the engine running above idle speed? It is a high amp motor so it needs the 14.5+ volts to help it run its best. With just the key on and volts in the 12’s it will be slow.
 
Last edited:
On my 70 I put in a new motor, rebuilt the box, and ran a relay to power the high speed. The relay was by far the thing that most improved the flow, but it still sucks.
The vintage air in my charger with it's newer fan and design flows a lot more
 
On my 70 I put in a new motor, rebuilt the box, and ran a relay to power the high speed. The relay was by far the thing that most improved the flow, but it still sucks.
The vintage air in my charger with it's newer fan and design flows a lot more
Love to see a quick and dirty schematic of where that fan relay would go. Sounds like a great idea …
 
On my 70 the resistor for low and medium is attached to the outside of the heater box. And then there's a straight through for high speed. The simple thing was to use the relay to power the straight thru since I never use the massively slower speeds.
You use the wire from the switch to that resistor board as the trigger for the relay and power from relay to the straight thru feed to fan.
 
@furous70 is right about rebuilding your heater box. If you can control the air flow, the blower mtr can only produce so much air. I have rebuilt many heater boxes for 69-73 C body cars and properly adjusted they can supply more than enough air. As a caution, measure the amperage draw of the blower mtr. Also check the effort it takes to rotate the squirrel cage on the blower mtr. Another possibility is a partial plugged blower housing courtesy of mice and squirrels. Contact Detroit Muscle Technologies about buying a foam seal kit. See the photo examples below.


DSC04400.JPG


DSC04401.JPG
 
Some of the blowers used a three coiled wire resister to control speed. The combination of the coils regulated the speed, and they get hot! You might want to take a quick peek and see if they are still passing current. For the sake of two screws and a terminal being removed, what have you got to lose? Also, a good ground is essential. Best of luck.
 
On A/C cars you can SEE the blower motor, but still have to pull the heater box out to replace it.
Non A/C slabs, ditto pull the box.
I agree with others, rebuild the box, new motor, check the resistor and install a rely on the circuit.
Eemember, the fan speed will increase with the engine speed when driving!
Of coursecit wikl run slower in the driceway just running on battery power.
Hope this helps.
 
Back
Top