76 ROYAL MONACO BROUGHAM IN KB8 ...NOT MINE...YET

Dobalovr

Being on the Cbody diet SUCKS!
FCBO Gold Member
Joined
Sep 3, 2015
Messages
5,588
Reaction score
7,532
Location
Calgary Alberta
Thanks Mark! Next time I’m on the left coast we will definitely need to go junkyarding....
 

marko

Senior Member
FCBO Gold Member
Joined
Dec 15, 2014
Messages
1,026
Reaction score
1,556
Location
Victoria, BC Canada
and here's where @Dobalovr 's hood ornament came from hehe

20180204_151225-1 (2).jpg
 

Dobalovr

Being on the Cbody diet SUCKS!
FCBO Gold Member
Joined
Sep 3, 2015
Messages
5,588
Reaction score
7,532
Location
Calgary Alberta
Sooooo giving the obvious lack of tune and poor carb condition what would you say is causing the excessive blue (oil burning) smoke any time you rev it above 1000RPMS....nothing at idle but under load or revving it up blue smoke...valve seals or burnt valve? Also have the D/S cornering lamp lit all the time while running. Power to ground as it dims in time with the turn signals I am guessing....and so it begins!
 

Mr C

Senior Member
Joined
Nov 20, 2012
Messages
4,351
Reaction score
4,175
Location
All over
heres 2 more rough ones besides mine here on Vancouver Island.
neither are running or complete anymore.
the blue one doesnt have alot of options, the black one has the optional upgrade interior like graham's. you can see the plain horn pad.
the dippy package was optional in 76 & 77.
i used to know roughly how many were made but can't find the info at the moment.
i think it was under 1,000 maybe under 800 for both years ?

mark

View attachment 253568

View attachment 253569

View attachment 253570

View attachment 253571

View attachment 253572

View attachment 253573

Mark,
I think that blue one with the white top is the car I passed on!!! It was in Courtenay in the 90's.
 

1978 NYB

Warfighter
Joined
Apr 16, 2011
Messages
72,125
Reaction score
50,119
Location
Classified
Sooooo giving the obvious lack of tune and poor carb condition what would you say is causing the excessive blue (oil burning) smoke any time you rev it above 1000RPMS....nothing at idle but under load or revving it up blue smoke...valve seals or burnt valve? Also have the D/S cornering lamp lit all the time while running. Power to ground as it dims in time with the turn signals I am guessing....and so it begins!
.

I would say valve guides and seals would be a big contributor to the blue smoke.
 

300rag

It's Not Going to Shift Itself
Joined
Dec 4, 2010
Messages
13,557
Reaction score
22,716
Location
Calgary, Alberta, Canada
Sooooo giving the obvious lack of tune and poor carb condition what would you say is causing the excessive blue (oil burning) smoke any time you rev it above 1000RPMS....nothing at idle but under load or revving it up blue smoke...valve seals or burnt valve? Also have the D/S cornering lamp lit all the time while running. Power to ground as it dims in time with the turn signals I am guessing....and so it begins!
Based on my own experience with a 76 400, I'll go with seals.#6 plug fouled up really quickly on mine.
 

1978 NYB

Warfighter
Joined
Apr 16, 2011
Messages
72,125
Reaction score
50,119
Location
Classified
I would refresh the heads for sure and you won't ever have to worry about them again.

It can go on and on....since you got it apart. Cam, lifters, push rods.

I ended up just putting a performance crate engine in mine.
 

Dobalovr

Being on the Cbody diet SUCKS!
FCBO Gold Member
Joined
Sep 3, 2015
Messages
5,588
Reaction score
7,532
Location
Calgary Alberta
I would refresh the heads for sure and you won't ever have to worry about them again.

It can go on and on....since you got it apart. Cam, lifters, push rods.

I ended up just putting a performance crate engine in mine.

Kinda like using a sledge hammer to hang a picture Bob??:poke:
 

Mr C

Senior Member
Joined
Nov 20, 2012
Messages
4,351
Reaction score
4,175
Location
All over
.
Was it a one year only option?

I've only seen another one a few years ago and it was very low mileage. I hesitated for a minute and someone swooped in and got it before I could pull the trigger.
The Diplomat package RMB was available in 76 &77, according to the dealership data books.
 

Dobalovr

Being on the Cbody diet SUCKS!
FCBO Gold Member
Joined
Sep 3, 2015
Messages
5,588
Reaction score
7,532
Location
Calgary Alberta
Soooo couldn’t take it any longer and switched out the off-centre horn pad for a spare Doba version - at least its centered. Also put the new Eddy AVS II on. Good news the bog is gone bad news is it has a miss or stumble that causes a popping through the exhaust at idle. Haven’t adjusted the timing yet but this rough idle makes me worried.....
A983E956-D9B8-48EC-ADE7-9FC71F8BBD0A.jpeg
08A1F108-2C45-45C8-9334-B01C7B713394.jpeg
 

patrick66

Old Man with a Hat
Joined
Jul 4, 2012
Messages
5,950
Reaction score
4,442
Location
Central Oklahoma
That second fender tag is an inspection stamp tag. As the car progressed down the line, the final inspector for that area (frame, etc) would apply his mark to the tag.
 

70bigblockdodge

Old Man with a Hat
Joined
Jan 19, 2013
Messages
13,121
Reaction score
10,510
Location
Avonmore Pa.
Popping in the exhaust is usually ignition miss fire and gas lights in exhaust.
I could be wrong but my last 2 problems with this have both come from bad spark plug wires ( me being a cheap ass and in a hurry) took the time with new wires and both cars cleaned up.
 

Dobalovr

Being on the Cbody diet SUCKS!
FCBO Gold Member
Joined
Sep 3, 2015
Messages
5,588
Reaction score
7,532
Location
Calgary Alberta
Next up plugs/wires/cap/rotor absolutely. They haven’t been done in a while. Also getting some blue smoke on acceleration so valve seals/guides likely.
 
Top